Back to overview
Degraded

Investigating issue with accessing voice recordings

Mar 17, 2026 at 10:00pm UTC
Affected services
Decagon Admin Portal

Resolved
Mar 17, 2026 at 10:35pm UTC

The issue is now resolved and voice recordings are again available through the Decagon admin portal. Thanks for your patience as we resolved this issue

Updated
Mar 17, 2026 at 10:30pm UTC

We've identified the issue and are rolling out a fix now. We will provide an update in the next 30min or when the issue is resolved.

Created
Mar 17, 2026 at 10:00pm UTC

We are currently investigating reports of users having trouble accessing voice recordings via the admin dashboard. We will provide an update within the next 30 minutes.