Back to overview
Degraded

Investigating Voice Degradation due to Twilio / AWS Downtime

Oct 20 at 11:42am PDT
Affected services
Decagon API Services

Resolved
Oct 20 at 05:07pm PDT

AWS and Twilio has reported full recovery, and we are observing stability in Decagon Voice. Customers should now be experiencing normal functionality.

Updated
Oct 20 at 05:07pm PDT

AWS and Twilio has reported full recovery, and we are observing stability in Decagon Voice. Customers should now be experiencing normal functionality.

Updated
Oct 20 at 03:25pm PDT

Twilio is still experiencing intermittent issues as confirmed by their team. We are following closely and will provide the latest updates.

Updated
Oct 20 at 01:11pm PDT

We are able to confirm the issue is due to Twilio / AWS outages. We are communicating closely with Twilio and will wait for their official confirmation before advising further

Updated
Oct 20 at 12:49pm PDT

We noticed signs of recovery for Twilio Outbound calls. Preliminary testing shows that call transfers are now going through for previously affected customers. We will further test and report back in ~15 minutes.

Created
Oct 20 at 11:42am PDT

Voice AI calls are experiencing issues around call transfers due to intermittent Twilio API failures. The team is currently investigating and will provide an hourly update on status.