Issue with admin dashboard logins
Resolved
Jul 27, 2026 at 1:06pm UTC
The issue affecting OTP email delivery has been resolved by our auth vendor and we are seeing full recovery across our customers. We’ll continue to monitor and will provide a preliminary post-incident review upon request within 48hrs.
Affected services
Updated
Jul 27, 2026 at 12:19pm UTC
We are seeing partial recovery in successful delivery of OTPs over email. Our team is monitoring performance and stability closely to determine if the issue is fully resolved.
Affected services
Created
Jul 27, 2026 at 11:42am UTC
We are investigating an issue with logins, where some users are not receiving their one time password required to access the dashboard. We are investigating with our authentication vendor and will provide an update in 30min or as we learn more.
Affected services