Back to overview
Resolved

Service interruptions - Resolved

Jul 10, 2026 at 4:35pm UTC
Affected services
[US] Decagon Admin Portal
[EU] Decagon Admin Portal

Resolved
Jul 10, 2026 at 5:30pm UTC

This issue has now been resolved.
Impact Window: 12:35pm – 1:25pm ET

Cause: An outage with a feature flag provider caused temporary impact on some features, which included disabling Duet. We'll continue to monitor and will provide a preliminary post-incident review within 48hrs. We will follow up with customers who may have experienced any additional impact. Thank you for your patience and understanding.

Updated
Jul 10, 2026 at 5:11pm UTC

Our systems are beginning to recover; some teams may be able to access Duet upon refresh. Our team is monitoring performance and stability closely. We'll provide another update once we confirm full resolution.

Updated
Jul 10, 2026 at 5:08pm UTC

We are continuing to investigate the service interruptions to our admin portal. Users may experience longer latency on simulation runs.

Created
Jul 10, 2026 at 4:35pm UTC

We are investigating impacts due to service interruptions with a feature flag provider we rely on. The current impact is that certain features, including Duet, will be temporarily disabled from our admin portal.