Back to overview
Degraded

Disruption to scheduled jobs

Jun 3, 2026 at 8:06am UTC
Affected services
[US] Decagon Admin Portal

Resolved
Jun 3, 2026 at 9:01am UTC

We have implemented a mitigation to enable jobs processing. Scheduled jobs are now executing as expected, and any delays to asynchronously processed tasks should clear shortly. Conversations across all channels were unaffected throughout the incident.

Created
Jun 3, 2026 at 8:06am UTC

We have identified a disruption affecting our background job infrastructure due to a GCP outage. Scheduled jobs may not be executing as expected, which could result in temporary delays to asynchronously processed tasks, such as Watchtowers and some analytics. Conversations across all channels (including voice, chat, email, and SMS) will continue without end user impact.

Our team is actively working on mitigation and will provide updates as the situation progresses.