Back to overview
Resolved

Delays in Conversation Search, Filtering, and Reporting

Sep 9, 2026 at 9:58pm UTC
Affected services
[US] Decagon Admin Portal

Resolved
Sep 10, 2026 at 12:35am UTC

This issue is resolved. Conversation search, filtering, listing, and alerting in the dashboard are now reflecting realtime data.

Live conversations were unaffected throughout, and no conversation data was lost. Records that appeared missing or delayed during the incident are now present.

We have deployed a change that serves these dashboard surfaces from a realtime data path, removing them from the delayed pipeline that caused this issue.

Updated
Sep 9, 2026 at 11:53pm UTC

The fix is in progress and currently being deployed. We will confirm here as soon as it is live.

Updated
Sep 9, 2026 at 10:46pm UTC

We are still working to mitigate this issue. Conversation search, filtering, and reporting remain delayed. Live conversations and AI responses are not affected, and no data has been lost.

Created
Sep 9, 2026 at 9:58pm UTC

We have identified an issue causing delayed results when searching or filtering conversations in the dashboard. Analytics, reporting, and filtered data exports may also reflect stale data. The cause is a delay in the data replication pipeline that feeds these surfaces.

Live conversations are not affected. The AI agent continues to respond to end users normally, and no conversation data has been lost. Delayed records will appear once replication catches up.

We are actively rolling out a mitigation solution. We will provide another update when that's live or in 30 minutes.