Conversations Not Loading in Dashboard
Resolved
Aug 31, 2026 at 7:05pm UTC
We have identified the root cause of this issue and a fix has been deployed. This issue is now resolved.
We’ll continue to monitor and will provide a preliminary post-incident review upon request within 48hrs.
Thank you for your patience and understanding.
Affected services
Created
Aug 31, 2026 at 6:56pm UTC
We're investigating an issue causing conversations to intermittently fail to load in the dashboard for some customers. This does not affect live conversation handling or agent performance. We're actively looking into the cause and will provide an update within 30 minutes.
Affected services