Intermittent instability affecting incoming calls
Resolved
Aug 20, 2026 at 5:25pm UTC
Service recovery is underway, and performance has returned to normal across all channels. Our team will continue to monitor the system closely to ensure ongoing stability.
Affected services
Updated
Aug 20, 2026 at 4:14pm UTC
We are experiencing a major service disruption due to degradations with our cloud service provider. We're seeing elevated incoming call failures and increased latency. Our engineering team is actively investigating and we'll continue to post updates.
Affected services
Created
Aug 20, 2026 at 2:58pm UTC
We are currently investigating intermittent instability. Some calls may experience increased latency or fail to connect.
Our team is actively working to identify the cause and restore normal service. We’ll share another update as soon as we have more information.
Affected services